Restore Additive worked!! - Fuelly Forums

Click here to see important news regarding the aCar App

Reply
 
Thread Tools Display Modes
 
Old 11-29-2019, 05:57 AM   #1
Out of Fuel
 
Join Date: Nov 2019
Posts: 3
Country: United States
Restore Additive worked!!

Has anyone had similar experience? I did not mind doing all below as I enjoy projects and working on cars. My main question is if others think Restore additive could really have fixed my problem. I almost would rather believed a clogged lifter cleared than an additive fixed my problem. I am just still in shock a little..

My wife’s 04 Tahoe starting having P300 Random Misfire Code. I purchased Torque App and setup a iPad to see all 8 cylinders real time. Cylinders 1 & 7 were misfiring. I could tell it was idling a little rough and when removing the plug wire on 1 or 7 offered little change so I confirmed it. I enjoy auto projects and car was old so started with basics. Fuel Pressure, Replaced Intake Manifold Gasket, since I had manifold off I replaced CAM sensor, Smoke Test (home made smoker) revealed no leaks but did see a small amount of smoke coming up out of oil cap. I went ahead and replaced plugs and cables as it was time. To be 100% I swapped/reverse the coil packs between bank 1 and 2 to prove coils were not the issue. This test moves all coils to a new cylinder and the problem remained on 1/7.

I decided to do compression and leakdown testing on cylinders. 2-8 were good with 190 - 210 range and all passed leak down. C1 was lower around 170 but still in range per Alldata specs. So I thought it’s not compression. I checked all air sensors like MAF and O2 and they were fine. I swapped injectors between rails 1 & 2 and no change. I became convinced watching YouTube that I likely had a worn CAM lobe or bad lifter. Again I like projects and needed to keep this vehicle running so I decided to change the Cam and Lifters. I purchased parts and gaskets from 1AAuto around June but it was summer and too hot so I decided to wait til October.

I saw YouTube video about RESTORE and decided to try it during an August oil change. In late September my wife told me we needed state inspections so I was nervous this issue would fail the inspection. The EL was in so I cleared codes and the EL and the inspection passed. However the EL never returned.. My iPad died but In mid October I was able to use my Torque App and text and all misfires were gone!!! GONE!!! Fuel Trims are perfect !!! The thing runs like new .... it sorta disappointed me as I have the parts and like to do projects but I cannot being myself to touch an engine that is running great....

All I can say is I am AMAZED at what Restore did for my problem.. I am adding Restore to every other oil change (twice a year) to see how it goes. I have no choice but to hold onto parts for now..
ChevyTex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Fuelly Android Apps
No Threads to Display.
Powered by vBadvanced CMPS v3.2.3


All times are GMT -8. The time now is 02:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.