Some of my recent 7.3 PSD mods... - Page 2 - Fuelly Forums

Android Users - Coming Soon! - Migrating from aCar 4.8 to 5.0

Reply
 
Thread Tools Display Modes
 
Old 07-25-2008, 08:13 PM   #11
Registered Member
 
GasSavers_SD26's Avatar
 
Join Date: Dec 2007
Posts: 529
Country: United States
It was all new to me. Last trip back from Topeka, it started loosing power, smoking. Just all bad. I though it might have been the turbo, but it felt very good. I needed to replace the turbo boot, and I just decided to look at the wiring connector there at the back...well, it was going... Need to get the valve cover off.
__________________

__________________
Dave
GasSavers_SD26 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Difficult w/ Fuelly & Blackberry Bster13 Fuelly Web Support and Community News 4 04-01-2012 12:39 PM
Where can I get a superMid? oneinchsidehop General Fuel Topics 2 10-05-2007 04:58 AM
Need addresses of recently upgraded members Matt Timion Fuelly Web Support and Community News 2 04-10-2007 06:17 PM
Electric bikes banned in Chinese city to make room for cars MetroMPG Electric and Solar powered 4 11-24-2006 08:29 AM
HTML in posts? MetroMPG Fuelly Web Support and Community News 2 07-21-2006 11:44 AM

Powered by vBadvanced CMPS v3.2.3


All times are GMT -8. The time now is 10:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.