EGR troubles (need an expert) - Fuelly Forums

Android Users - Coming Soon! - Migrating from aCar 4.8 to 5.0

Reply
 
Thread Tools Display Modes
 
Old 02-09-2010, 04:43 AM   #1
Registered Member
 
GasSavers_BEEF's Avatar
 
Join Date: Apr 2008
Posts: 1,831
EGR troubles (need an expert)

my car lately has been throwing an error code (p1404) which means the EGR is stuck open or closed or something. this is an issue that I have been dealing with for a while.

what I have done:
cleaned the EGR valve twice (replacing the gasket both times)
purchased a new EGR valve and replaced the old one

the code came back on me yesterday. there is a website where you can ask questions of ASE certified experts. I have joined that site (it is a pay site) and am having difficulties with the site. you are supposed to be able to ask follow up questions but for some reason I just can't get it to work and their customer service hasn't responded to me.

here is what he said.

Hello!

P1404

Tests/Procedures:

1. Disconnect the battery and touch the cables together for a couple minutes. Reconnect and then check actual percentage and see if the actual egr matches the desired egr position.

2. If not, then use the scanner, and in the functional test area see if the scanner offers a reset for learn EGR value.

3. If the scan tool does not do this, then would have the Powertrain Control Module (PCM) flashed with the latest software.

Potential Causes:

Powertrain Control Module (PCM)
Powertrain Control Module (PCM) Reflash


if anyone knows what I need to have to monitor the positon of the EGR valve or what it might cost to reflash my PCM, please let me know.

I am pretty sure the scangauge won't tell me what I need to know.

I am thinking of just disconnecting the battery and shorting the leads to see if a reset will fix it.

any information is greatly appreciated.
__________________

__________________
Be the change you wish to see in the world
--Mahatma Gandhi



GasSavers_BEEF is offline   Reply With Quote
Old 02-09-2010, 09:18 AM   #2
Registered Member
 
VetteOwner's Avatar
 
Join Date: Mar 2007
Posts: 1,546
Country: United States
try the reset after all its free.

im assuming you have the 2.2L?

thats what my truck is and i completely removed the egr and just blocked it off with a plate. still throws the ses light but meh i know whats causing it
__________________

VetteOwner is offline   Reply With Quote
Old 02-09-2010, 09:23 AM   #3
Registered Member
 
GasSavers_BEEF's Avatar
 
Join Date: Apr 2008
Posts: 1,831
I plan on doing the reset tonight.

my big problem is that I need the CEL off to pass inspection and I am pretty sure the system has to be in the "READY" state to pass as well. inspection is due in march.

if I can get it past this inspection period, I don't really think I care much about it.

and it is the 2.2
__________________
Be the change you wish to see in the world
--Mahatma Gandhi



GasSavers_BEEF is offline   Reply With Quote
Old 02-09-2010, 03:23 PM   #4
Registered Member
 
VetteOwner's Avatar
 
Join Date: Mar 2007
Posts: 1,546
Country: United States
ohhh sucks about inspections...

hmm might be cheaper to find a PCM out of the same year and model of car at a junkyard for cheaper...
VetteOwner is offline   Reply With Quote
Old 02-10-2010, 07:49 AM   #5
Site Team
 
Join Date: Dec 2006
Posts: 656
Country: United States
So it sounds like the EGR is not working because the PCM is not giving it a good signal? Unless there is a blown fuse or something, it sounds like the only other fix is to replace the PCM. That's really annoying since 99.99999% of the PCM is working fine, just the output control to the EGR is broken.

It might not hurt to do a continuity check in the wires too. Just in case a wire got pinched or something, and the signal is being sent by the PCM but the valve can't "hear" it.

I'm assuming you don't have a scan tool.

-Bob C.
__________________
Think you are saving gas? Prove it by starting a Gas Log, then conduct a proper experiment.
bobc455 is offline   Reply With Quote
Old 02-10-2010, 08:10 AM   #6
Registered Member
 
GasSavers_BEEF's Avatar
 
Join Date: Apr 2008
Posts: 1,831
I checked on a scantool and they run in the neighborhood of $6k so I don't plan to get one and I am not a mechanic by trade so I don't have access to one.

I did find a guy on ebay that sells PCMs and he flashes them for you before he sends them. he uses your vin to get the specifics of your vehicle (ie. motor size, transmission, other stuff) he charges just under $100 shipped.

that is a consideration but for now, I have reset the pcm (just unhooked the battery for a few hrs) and I am going to run it for a week or so. if the light does come back on, I will look into tracing wires before purchasing anything.

for now, I am waiting and watching. if I can get it to say "READY" even for just a little while, I can get an inspection and not worry about it. if the light comes back on after that, it isn't that big of a deal.
__________________
Be the change you wish to see in the world
--Mahatma Gandhi



GasSavers_BEEF is offline   Reply With Quote
Old 02-13-2010, 09:25 AM   #7
Registered Member
 
GasSavers_BEEF's Avatar
 
Join Date: Apr 2008
Posts: 1,831
UPDATE (and a sigh of relief)

after 120ish miles, my car finally go to the "READY" state and a raced out and got inspected. hopefully that was my problem.

even if the problem comes back, now I have a year to deal with it.

thanks to all.
__________________

__________________
Be the change you wish to see in the world
--Mahatma Gandhi



GasSavers_BEEF is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cars/Trucks - Overachievers. GeneK General Fuel Topics 7 09-06-2009 09:36 AM
Hi !! Any Suzuki Drivers Here ??? fitsandy Introduce Yourself - New member Welcome 1 09-09-2008 04:44 PM
Stealth / Performance Exhaust System Hybrid JohnNeiferd General Fuel Topics 9 07-27-2008 03:40 PM
Fess up, which one of you owns this thing? GasSavers_ALS General Fuel Topics 5 05-07-2008 05:24 PM
Happy 1st Anniversary Geo! Peakster General Discussion (Off-Topic) 11 08-20-2007 08:07 AM

Powered by vBadvanced CMPS v3.2.3


All times are GMT -8. The time now is 07:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.