Oxygen Sensor? - Fuelly Forums

Android Users - Coming Soon! - Migrating from aCar 4.8 to 5.0

Reply
 
Thread Tools Display Modes
 
Old 04-08-2008, 08:50 PM   #1
Registered Member
 
Join Date: Apr 2008
Posts: 23
Country: United States
Oxygen Sensor?

My Hyundai Accent has 160K miles. I've had it since 86K on the odo.

A couple months ago, the Check Engine light came on. Pulled the code and IIRC it was an 02 sensor code. I reset it and the light didn't come back on for a month, so I figured it was a stray data # that came through the ECU or something. Light popped on after that month or so. (I drive 2400 miles+/month) So I again cleared it. That was a week ago.

I have a Scangauge now, and after several hundred miles, it still shows the ECU as "Not Ready." How long should this take!?

Either way, I'm assuming from what I know now from what I've read here that the O2 sensor is likely on it's way out? (I've never replaced either of them on this car)

Reason I really suspect this is I've been driving MUCH better for FE, yet see no improvement. I get ~36 MPG over time whether I do 72 or 60. That does NOT seem right at all. In the past when I would even slow down to 67 instead of 70-72 and take it easy, I could get 39-40 MPG easy.

Does it make sense that a near-bad 02 sensor could cause this, but not throw on the Check Engine Light right away?
__________________

__________________
-Nate R
96 Hyundai Accent 5 Spd


Nate R is offline   Reply With Quote
Old 04-09-2008, 07:49 AM   #2
Registered Member
 
GasSavers_RoadWarrior's Avatar
 
Join Date: Feb 2008
Posts: 1,652
Sometimes they don't throw codes for the O2 sensor per-se, but will come up with stuff like...

"Injector pulse width too low"

Meaning, "Hey this here sensor is telling me it's lean, but somehow I can't seem to hose enough gas in to richen it"

But it sounds like you're not actually in closed loop mode, this could be for several reasons, like the coolant temp sensor being bad, or the MAP/MAF being bad.
__________________

__________________
I remember The RoadWarrior..To understand who he was, you have to go back to another time..the world was powered by the black fuel & the desert sprouted great cities..Gone now, swept away..two mighty warrior tribes went to war & touched off a blaze which engulfed them all. Without fuel, they were nothing..thundering machines sputtered & stopped..Only those mobile enough to scavenge, brutal enough to pillage would survive. The gangs took over the highways, ready to wage war for a tank of juice
GasSavers_RoadWarrior is offline   Reply With Quote
Old 04-09-2008, 09:13 AM   #3
Registered Member
 
Join Date: Apr 2008
Posts: 23
Country: United States
Quote:
Originally Posted by RoadWarrior View Post
But it sounds like you're not actually in closed loop mode, this could be for several reasons, like the coolant temp sensor being bad, or the MAP/MAF being bad.
SG says I am in closed loop. As of now, the light is not on, but it's been a week since I reset it and the SG still says not ready.
__________________
-Nate R
96 Hyundai Accent 5 Spd


Nate R is offline   Reply With Quote
Old 04-09-2008, 04:47 PM   #4
Registered Member
 
Join Date: Mar 2006
Posts: 675
Country: United States
I would suggest you go ahead and replace the Oxygen sensor. As they get on, their responsiveness to changes slow down and they don't necessarily get bad enough to throw a hard fault, most of the time, but they don't work right, either.
Gary Palmer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Monkeywrench Gang by Edward Abbey repete86 General Discussion (Off-Topic) 2 07-26-2008 10:58 PM
New Ride cartuch Introduce Yourself - New member Welcome 5 10-22-2007 03:02 PM
What next? billynjoanna Aerodynamics 19 09-05-2007 10:31 AM
Noob trying to save in gas! GasSavers_Bigfoot Introduce Yourself - New member Welcome 1 05-31-2007 01:17 PM

Powered by vBadvanced CMPS v3.2.3


All times are GMT -8. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.