Fuelly Forums

Fuelly Forums (https://www.fuelly.com/forums/)
-   Fuelly Web Support and Community News (https://www.fuelly.com/forums/f2/)
-   -   Number Section of iOs keyboard (https://www.fuelly.com/forums/f2/number-section-of-ios-keyboard-1193.html)

boostventilator 09-04-2012 12:52 AM

Number Section of iOs keyboard
 
I noticed I access Fuelly mostly from the mobile version of the site and was wondering if it was possible to default to the numerical keyboard for data entry.

Forcing a numeric keypad will miss the decimal point (which would be find for odometer readings):

input type="text" pattern="[0-9]*"

…but using the HTML5 specification for a number field in a form will at default to the number page of the standard iOs keyboard for price and gas:

input type="number"

More info.

pb 09-04-2012 01:46 AM

We already show the numeric keypad on the mobile site. We don't want to use the phone keypad (which doesn't have a decimal point or comma) because some people do track their odometer to a decimal place.

lancea 09-07-2012 12:16 AM

Was something changed on the mobile site recently?

I cannot use my Android ICS phone to enter decimal points in the Litres or Price/Litre text fields today :(

pb 09-07-2012 12:28 AM

lancea, this is a problem with recent versions of some Android phones. It seems to be limited to Samsung models so far. For some inexplicable reason, they decided that a decimal point wasn't necessary on the numeric keypad. It's very frustrating to be on this end—there's nothing we can do about it.

You can visit this page on your phone:

https://m.fuelly.com/disable-numeric-keypad.gas?id=1

That will tell Fuelly Mobile not to use the numeric keypad for entry. You'll have to navigate to the numbers each time, but that should be faster than switching keypads.

lancea 09-07-2012 05:57 AM

Thanks pb, that did the trick. I have a galaxy s3.

MD1032 09-23-2012 09:23 AM

Just recently, on my Galaxy S3's default browser, the number pad shows up, but the decimal point and "symbols" buttons are grayed out. It's weird, because they used to work when I first got the phone.

I figured out that it's easily fixed by simply telling the Galaxy to use "desktop view", which will bring up a full size keyboard.


All times are GMT -8. The time now is 09:40 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.