Fuelly Forums

Fuelly Forums (https://www.fuelly.com/forums/)
-   General Maintenance and Repair (https://www.fuelly.com/forums/f10/)
-   -   A funny thing happened to the Geo on the way to this forum... (https://www.fuelly.com/forums/f10/a-funny-thing-happened-to-the-geo-on-the-way-to-this-forum-12013.html)

GasSavers_JoeBob 10-11-2009 08:35 PM

A funny thing happened to the Geo on the way to this forum...
 
So yesterday I decided it was time (well, actually it was quite overdue) to change the oil in my Geo. Looked underneath, there was some schmutz. So I did what I usually do...go up to the neighborhood coin-op car wash. Clean the car off, clean off the engine. Drove to the drying area, everything OK. Went to leave, the car starts bucking, and I can't get over 10mph. Limp home.

When I get home, I determine that the car will idle just fine. When I rev the engine, it goes up, down, up, down at about a one cycle per second rate. I put the timing light on the car, it shows that there is normal spark. I pull the air cleaner and look down the throttle body, I see the fuel injector working normally at idle, then cycling itself off and on at a 1 cps rate. Everything works fine when car first starts, then starts cycling at anything above idle after 10 sec. No trouble codes.

I clean out most of the electrical connections going to the injectors, no change.

Today, I tried again...it worked better, hasn't cleared up completely, but the car can be driven. I'm now thinking maybe some moisture in the TPS, or perhaps the TPS connector. Or it could be something else. Does this sound familiar to anybody?

bobc455 10-12-2009 02:42 AM

Quote:

Originally Posted by JoeBob (Post 142891)
Does this sound familiar to anybody?

Sure sounds like you got part of the ignition system wet, for sure. But I don't see how that could happen by just spraying down the bottom of the engine, unless there was a lot of upward-splashing.

-Bob C.

Jay2TheRescue 10-12-2009 06:51 AM

My guess is ignition as well. You can get ignition drier in an aerosol can, I forget what trade name it sells under. Remove the distributor cap, spray it out, re-install it. If that doesn't solve your problem you will have to individually take each wire off the cap and the plugs, spray it & the terminal off, then reinstall, and don't forget to put a small dab of silicone grease on the inside of the boot to help prevent this from happening again.

GasSavers_JoeBob 10-12-2009 07:22 PM

Cleaned out all the moisture from the distributor cap, made no difference. BTW, I did clean from the top down as well as from the bottom up. Probably a little moisture in one of the myriad of connectors going various places in the engine compartment. I'm mostly curious about the 1 cps cycling...

markweatherill 10-12-2009 11:30 PM

Maybe there's a vacuum leak - a hose dislodged by the jet washer?

JanGeo 10-13-2009 07:20 AM

Check the MAP sensor on the passenger side firewall and the hose that connects it to the intake manifold as well as any cross feeding lines along the firewall behind the air filter. It is the little square thing that looks like a relay but isn't with at least 1 hose comming out the bottom of it mounted up high on the firewall near the heater motor.

FrugalFloyd 10-13-2009 09:16 AM

I'm with the others thinking vacuum hose or intake manifold leak. You probably dislodged some gunk that was sealing it closed.

JanGeo 10-13-2009 02:21 PM

Hey Darrell are you following my around? Didn't I just post on SL?


All times are GMT -8. The time now is 04:18 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.