VSS issue - Fuelly Forums

Android Users - Coming Soon! - Migrating from aCar 4.8 to 5.0

Reply
 
Thread Tools Display Modes
 
Old 03-16-2008, 09:07 AM   #1
Registered Member
 
vxdude's Avatar
 
Join Date: Feb 2008
Posts: 93
Country: United States
Send a message via Yahoo to vxdude
VSS issue

folks,

My Civic VX's speedometer has stopped working. I replaced the Vehicle Speed Sensor, but my speedometer is still wacked. Whats going on with this thing. No Cels, although it does start to work a little about 30mins of driving. its a 1995 with 93,XXX. ohh and i have unhooked the neg. side battery terminal. PLEASE HELP!!!
__________________

vxdude is offline   Reply With Quote
Old 03-16-2008, 09:55 AM   #2
Registered Member
 
vxdude's Avatar
 
Join Date: Feb 2008
Posts: 93
Country: United States
Send a message via Yahoo to vxdude
also along with the speedometer not working the odometer doesnt work either and the shift light. But i think all of that works off of the VSS.
__________________

vxdude is offline   Reply With Quote
Old 03-16-2008, 01:13 PM   #3
Registered Member
 
Join Date: Sep 2006
Posts: 409
Country: United States
yes those are all vss related, are you sure you have the correct VSS for your car? Otherwise you might want to SEARCH honda-tech for some help, they have a lot more expertise in this department. the only other thing i can think is your speedometer its' self is screwed up, or badly grounded? Wish i could be more help.
__________________
red91sit is offline   Reply With Quote
Old 03-16-2008, 01:34 PM   #4
Registered Member
 
Join Date: Aug 2007
Posts: 107
Country: United States
In the service manual it says to jack up the front end, hook up a voltmeter tp the vss, spin the tire and you should get 4 pulses, of 5 volts, per revolution of the tire, at least on a crx. If you are getting the pulses at the vss then try at the end of the wire at the cluster. If no then it's a wiring problem if so it's probably something in the cluster. Have you lost any screws in thnere? On the CRX there is a ledge, that a screw could land on, shorting out the circut board on the back of the cluster.

Another thing you could check is to see if the cel comes on correctly for a non working vss. It will not come on until injector shutoff on decel cause then it knows for sure it is not idling. Take it up to 3K RPM in second and pull your foot off the gas. If the ECU is not getting VSS signal the Check Engine Light will come on
FritzR is offline   Reply With Quote
Old 03-16-2008, 05:32 PM   #5
Registered Member
 
vxdude's Avatar
 
Join Date: Feb 2008
Posts: 93
Country: United States
Send a message via Yahoo to vxdude
okay, the little test worked. What i did was disconnected the VSS plug thing. Then put it in 2nd gear at 3,000 rpm and let the gas go, low and behold the cEL came on. So i know the wiring still works. Next i took the ECU fuse out put the VSS plug back on, plugged back the fuse, and drove away. As of right now the speedometer works, but then again the car was already at operating temp. So we will see in the morning. But thanks.. let me know if it could be anything else.
vxdude is offline   Reply With Quote
Old 03-16-2008, 05:33 PM   #6
Registered Member
 
vxdude's Avatar
 
Join Date: Feb 2008
Posts: 93
Country: United States
Send a message via Yahoo to vxdude
one more thing, i also did the same test with everything plugged in and no CEL....
vxdude is offline   Reply With Quote
Old 03-18-2008, 10:49 AM   #7
Registered Member
 
Join Date: Aug 2007
Posts: 107
Country: United States
When you reset the ECU by pulling the hazard fuse you should let the car idle for several minutes without hitting the gas or putting a load on it for it to calibrate itself
FritzR is offline   Reply With Quote
Old 03-20-2008, 04:57 PM   #8
Registered Member
 
1993CivicVX's Avatar
 
Join Date: Aug 2007
Posts: 1,066
Country: United States
Send a message via AIM to 1993CivicVX
From my own experience and what a mechanic will probably tell you: your cluster needs to be replaced. My car has the same problem... the speedometer/odometer work about 60% of the time. Replaced the VSS but had zero effect. Does anyone have any idea how much it would cost to have a mechanic take out the old cluster and install the new one?
__________________
three stripes the charm!

Car mods are overrated. Just gotta adjust that nut behind the wheel for best mpg.



Forget about World Peace...Visualize using your turn signal.
1993CivicVX is offline   Reply With Quote
Old 03-20-2008, 05:20 PM   #9
Registered Member
 
Join Date: Aug 2007
Posts: 107
Country: United States
Not sure of the VX but on my crx the cluster replacement I just did took 15 minutes. 4 screws to get the cluster hood off. Two in the front on the underside corners. Two in the back on top under the little pry off door things. Then four screws on the front edges of the cluster. Three wire connectors and the speedo cable, but you wouldn't have that being electronic. The hardest part is figuring out that you have to stand outside the car, look through the winshield, and reach in the window to replace the front when replacing the cluster hood.

Also don't buy new parts from honda for this. The cluster is way over $1K, $500 just for the speedo. I got mine on ebay for $50
FritzR is offline   Reply With Quote
Old 03-20-2008, 05:23 PM   #10
Registered Member
 
1993CivicVX's Avatar
 
Join Date: Aug 2007
Posts: 1,066
Country: United States
Send a message via AIM to 1993CivicVX
cool, thanks! Maybe it something I could do myself, although I *still* haven't installed the ECU I bought last year!!
__________________

__________________
three stripes the charm!

Car mods are overrated. Just gotta adjust that nut behind the wheel for best mpg.



Forget about World Peace...Visualize using your turn signal.
1993CivicVX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuelly Requests S4Lee Fuelly Web Support and Community News 8 10-17-2011 01:28 AM
Not so Smart aerodynamic fairing GasSavers_Antoine Aerodynamics 12 10-23-2007 03:59 PM
Brakes 1993CivicVX General Fuel Topics 3 10-05-2007 04:27 AM
what more can I do? kitcar Aerodynamics 19 06-18-2007 03:34 PM
Poll: Should Stability Control be Standard rh77 General Fuel Topics 14 09-30-2006 10:44 PM

Powered by vBadvanced CMPS v3.2.3


All times are GMT -8. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.